My name is Mihaly Fazekas.
I'm from Hungary.
Sorry, my english is not good.
I'm install boinc to one of HP Proliant DL320 machine.
(OS: FreeBSD 7, arch: amd64, linux emulation, ...)
Attach the Einstein@home project.
After download the data, and start the linux application, the (host) system send a message: "binary ELF type 0 not known".
After i change elf type (0->3 with brandelf command), the boinc/einstein send a message "Signature verification failed.....".
Other boinc project not send error message, when i cahenge elf type, and again other project can send a correct elf binaries.
Ok, i understand why sign executabel, etc....
But... :)
(Yes, linux emulation on FreeBSD, because i canot find FreeBSD-amd64 application)
What can i do?
(Or where can i download the good executables?)
Thak you for answers.
Copyright © 2024 Einstein@Home. All rights reserved.
problem based on linux ELF executable type (on FreeBSD)
)
According to this page
http://boinc.berkeley.edu/trac/wiki/DownloadOther
Einstein doesn't do FreeBSD, Seti does though. That page was last updated in 2007 though so hopefully a Mod or Admin can help you with more up to date info.
Well, there is no BSD app
)
Well, there is no BSD app right now but BSD (and OpenSolaris on x86) do offer support for running Linux executables in some kind of emulation mode. This works "more or less". I don't have a BSD system, but the problem here seems to be running a 32 bit Linux app on a 64 bit BSD system which involves two levels of potential compatibility conflicts.
Any tools that change the executable MUST result in signature violation errors because that's what the signature mechanism is supposed to do: prevent modifications of the apps.
Using an app_info.xml file (anonymous platform) would be a solution, but quite frankly, I think the honest advise given all the potential problems is to select a project that offers native BSD apps. I think the Linux emulation mode on BSD just isn't reliable enough and you risk too many wasted CPU cycles.
CU
Bikeman
FreeBSD 7.1+amd64 (freebsd
)
FreeBSD 7.1+amd64 (freebsd 7.0 i386 also works)
http://terresoft.blogspot.com/2009/02/normal-0-false-false-false-ru-x-none-x.html
1. kldload linux (&& echo linux_enable=�YES� >> /etc/rc.conf)
2a. sysctl kern.elf32.fallback_brand=3 (&& echo kern.elf32.fallback_brand=3 >> /etc/sysctl.conf)
2b. sysctl compat.linux.osrelease=2.6.16 (&& echo compat.linux.osrelease=2.6.16 >> /etc/sysctl.conf)
3. download linux_base-fc6-6_5 from ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-7.1-release/emulators/linux_base-fc6-6_5.tbz
4. pkg_add linux_base-fc6-6_5.tbz (linux_base-fc6-6_5 support x32/x64 and release 7.0/7.1)
5. cd /usr/ports/net/boinc-client
ee Makefile
6. change line
CONFIGURE_ARGS=--disable-server
CONFIGURE_ARGS=--disable-server --with-boinc-platform=i686-pc-freebsd
save quit
7. make config
[ ] X11 Build Boinc Manager X11 (if you have only console)
[X] ALT Accept Linux science application
8. make install clean
9. ee /usr/local/etc/rc.d/boinc
change line
boinc_flags="--dir ${boinc_home}"
boinc_flags="--dir ${boinc_home} --skip_cpu_benchmarks"
save quit
10. echo boinc_enable="YES" >> /etc/rc.conf
11. /usr/local/etc/rc.d/boinc start
all works without "app_info.xml".